View Issue Details

IDProjectCategoryView StatusLast Update
0000119JamochaMUDUser Interfacepublic2008-02-03 15:57
ReporterjeffnikAssigned Tojeffnik 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.2 rc2 
Target VersionFixed in Version2.7 
Summary0000119: Ability to double-click on links, activating them in another program
DescriptionAbility to double-click on links, activating them in another program, such as launching a URL in a web browser, etc.
TagsNo tags attached.

Activities

jeffnik

2005-11-12 00:28

administrator   ~0000091

A new method of launching a web browser has been implemented that will make use of the Java Webstart services. If these services are not available (apparently when the program is launched stand-alone), JamochaMUD will use a standard RunTime.exec command.

jeffnik

2005-11-20 15:56

administrator   ~0000093

Under KDE on Linux double-clicking on a link opens a view to the local file-system and a new version of the Konquerer web browser. Also, double-clicking does not always capture the entire URL as expected.

jeffnik

2007-01-28 21:47

administrator   ~0000115

Using the BrowserLauncher2 package JamochaMUD should now be able to successfully launch links via double-clicking.

jeffnik

2007-02-10 18:03

administrator   ~0000116

Due to a bug in the Windows implementation of the JDK, the values returned by getSelectedText() do not match those returned by the methods getSelectionStart() and getSelectionEnd(). This means on the Windows platform JamochaMUD cannot successfully pull the complete URL from the text.

jeffnik

2008-02-03 15:57

administrator   ~0000142

A work-around has been created for this.

JamochaMUD takes the String from the "getSelectedText()" method and the index of the erroneous "getSelectionStart()" method. JamochaMUD then searches from the getSelectionStart index looking for the string that matches the getSelectedText(). Now that we have the actual index, we can process the URL.

This is painful, but should now work whether Sun fixes this bug or not. Plus, I don't think there is too much of a performance hit, either.

Issue History

Date Modified Username Field Change
2005-10-29 01:22 jeffnik New Issue
2005-11-12 00:28 jeffnik Note Added: 0000091
2005-11-12 00:28 jeffnik Status assigned => feedback
2005-11-20 15:56 jeffnik Note Added: 0000093
2007-01-28 21:47 jeffnik Status feedback => resolved
2007-01-28 21:47 jeffnik Fixed in Version => 4.9
2007-01-28 21:47 jeffnik Resolution open => fixed
2007-01-28 21:47 jeffnik Note Added: 0000115
2007-02-10 18:03 jeffnik Status resolved => feedback
2007-02-10 18:03 jeffnik Resolution fixed => reopened
2007-02-10 18:03 jeffnik Note Added: 0000116
2008-02-03 15:57 jeffnik Status feedback => resolved
2008-02-03 15:57 jeffnik Fixed in Version 1.7 => 4.9
2008-02-03 15:57 jeffnik Resolution reopened => fixed
2008-02-03 15:57 jeffnik Note Added: 0000142