View Issue Details

IDProjectCategoryView StatusLast Update
0000192JamochaMUDMain Programpublic2008-04-19 14:46
ReporterjeffnikAssigned Tojeffnik 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.8 
Target VersionFixed in Version2.85 
Summary0000192: Create version control for preference modules
DescriptionA system should be implemented that allows preference modules to disable themselves if the current system does not meet its running requirements.

For example, the Spellchecking feature uses generics, which requires Java 1.5 or higher. The preference dialog for the spell-checker should let the user know why they can't modify the settings.
Additional InformationIn addition to doing the version check, we'll allow the preference panels to have a separate method showing details about why it is disabled.
TagsNo tags attached.

Activities

jeffnik

2008-04-19 14:46

administrator   ~0000152

New methods have been added to the PrefPanels interface to allow a "version check" where the module itself can determine if it has everything it needs and return true or false to the query.

Issue History

Date Modified Username Field Change
2008-04-19 14:01 jeffnik New Issue
2008-04-19 14:01 jeffnik Status new => assigned
2008-04-19 14:01 jeffnik Assigned To => jeffnik
2008-04-19 14:46 jeffnik Status assigned => resolved
2008-04-19 14:46 jeffnik Fixed in Version => 4.9
2008-04-19 14:46 jeffnik Resolution open => fixed
2008-04-19 14:46 jeffnik Note Added: 0000152