View Issue Details

IDProjectCategoryView StatusLast Update
0000199JamochaMUDUser Interfacepublic2008-06-30 02:03
ReporterjeffnikAssigned Tojeffnik 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2.9 
Target VersionFixed in Version3.1 
Summary0000199: Output to a MU* from a puppet window should automatically pre-pend the puppet information.
DescriptionWhen viewing a puppet window, an option should be given to automatically prepend the puppet name to the command.

If a player using the puppet Zom types "look", the output that is sent to the MU* should be "zom look". In this way the player will not have to prepend "zom" to the beginning of everything to get a puppet to perform the action. One would assume looking at the zombie/puppet window it is the zombie they want to use.
TagsNo tags attached.

Activities

mm0qq

2008-06-22 20:26

reporter   ~0000162

Would also be desirable to allow either specifying a prefix and/or the the actual command. For example, the control commands for all of my zombies begin with "r", so for a zombie named "Jeeves" the command would be "rJeeves". The option to specify the command would help players who are not so consistent in their zombie naming. Also, it would help in some games with in-games sales of special zombies with special in-game abilities, such as familiars, gollums and robots.

PS I just discovered this project in a Freshmeat listing. Looks promising.

jeffnik

2008-06-22 21:51

administrator   ~0000164

The Wiki documentation for the puppet window has been updated; I think I previously used the wrong description of the puppet command. The /puppet command should actually be "/puppet puppetcommand".

So if the puppet is named Jeeves but the command is rJeeves, the command should probably be issued as "/puppet rJeeves". Of course, there is still the assumption that the output from the MU* would be "rJeeves>".

Does this fit what you are suggesting?

If so, then I can update the command so it is "/puppet puppetcommand [puppetname]".

mm0qq

2008-06-23 00:37

reporter   ~0000165

Either would work, though I think most users would prefer:
/puppet puppetname [puppetcommand]

jeffnik

2008-06-23 01:55

administrator   ~0000166

Okay... proposed command:
/puppet puppetname [puppetcommand]
If the player doesn't supply a puppet-command, then JamochaMUD will assume that it is to watch for puppetname with > appended.

So, in the event of:
/puppet Fluffy zom>
JamochaMUD will refer to the puppet connection as Fluffy@, but will pipe any output starting with "zom>" to the Fluffy window.

By specifying exactly what to look for in the puppet-command, it makes it "impossible" for JamochaMUD to automatically prepend the proper command to send input back to the MU* by itself, the user would always need to type "zom Do this", because JMUD can't assume that ">" is the correct character to remove.

We could have the puppet-command automatically (or have a user-defined prepend), but I'm wary of the output becoming too messy.

I also haven't used a lot of other MU*s, so I don't know if the ">" is a standard thing across MU*s, or if there can be other characters used instead.

mm0qq

2008-06-24 01:47

reporter   ~0000167

Re your question: While "puppetname>" seems to be standard on MUCKs, I have seen different formats on MUSHes, MUXes and a few other MU*s. Some examples I have seen are: ">puppetname", "*puppetname" and "puppetname*".

Personally, I like the approach of giving the command exactly what to look for. But some people might find this too much work, so my next choice would be a per world setting with substitution (and, preferably, regular expression).

Example 1 (default): %n>

This would be the default setting, where %n is the puppet name.

With this setting, the command: /puppet Fluffy zom
would set the trigger to "Fluffy>" and the prefix to "zom"

Example 2: >%n

So, the trigger would be ">Fluffy" and the prefix "zom"

Supporting regular expressions would enable coverage of OOC chat, pages, whispers and shouts of various kinds.

Example 3: (>%n)|(%n pages)

The trigger expression would be "(>Fluffy)|(Fluffy pages)"

So, my proposel is: /puppet puppetname [puppetcommand]

If puppetcommand is not supplied, then it will default to puppetname.

Example 4: /puppet Fluffy

Trigger is "Fluffy>" (assuming the default setting)
Command prefix is "Fluffy"

Example 5: /puppet Fluffy rFluffy

Tigger is: "Fluffy>" (assuming default setting)
Command prefix is: "rFluffy"

(Note: I am going to look at the Java code and see if I can manage this myself. I realize I am asking a lot, here.)

jeffnik

2008-06-30 02:03

administrator   ~0000168

The /puppet command has now been updated to allow the user to give not only the puppet name, but the output to look for from the connected MU* and also automatically pre-pend the appropriate "send command".

Issue History

Date Modified Username Field Change
2008-06-21 13:39 jeffnik New Issue
2008-06-21 13:39 jeffnik Status new => assigned
2008-06-21 13:39 jeffnik Assigned To => jeffnik
2008-06-22 20:26 mm0qq Note Added: 0000162
2008-06-22 21:51 jeffnik Note Added: 0000164
2008-06-23 00:37 mm0qq Note Added: 0000165
2008-06-23 01:55 jeffnik Note Added: 0000166
2008-06-24 01:47 mm0qq Note Added: 0000167
2008-06-30 02:03 jeffnik Status assigned => resolved
2008-06-30 02:03 jeffnik Fixed in Version => 4.9
2008-06-30 02:03 jeffnik Resolution open => fixed
2008-06-30 02:03 jeffnik Note Added: 0000168