View Issue Details

IDProjectCategoryView StatusLast Update
0000203JamochaMUDMain Programpublic2008-07-30 02:43
Reportermm0qqAssigned Tojeffnik 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version3.4 
Summary0000203: "Connect Only" does not connect
DescriptionFrom the connector dialog, I select a world, then click on "Connect Only". dialog disappears and nothing else happens.

If I have just launched JamochaMUD, then JamochaMUD completely disappears - IE, no window displayed, not icon in the task bar. Program continues to run, invisably. Only way to stop program is to open the Task Manager to end it.
Additional InformationWindows XP SP2
JamochaMUD JAR file dated Jul 6, 2008
TagsNo tags attached.

Activities

jeffnik

2008-07-16 01:14

administrator   ~0000171

Due to new "puppet" code added, a null-pointer error was being thrown. This has now been fixed.

mm0qq

2008-07-28 20:33

reporter   ~0000179

Updated to JM 3.3
"Connect Only" not only failed to initiate a connection (I was monitoring the netwaork activity log), but it also corrupted the entry I was trying to connect.

FYI, double clicking the entry did work, however, it performed a "Save and Connect" (I know this because the write time stamp of the worlds file was updated)

jeffnik

2008-07-30 02:43

administrator   ~0000184

I believe the error has been corrected now. The implementation of the class makes it difficult to create useful JUnit tests against it; this will have to be fixed.

Issue History

Date Modified Username Field Change
2008-07-14 19:46 mm0qq New Issue
2008-07-14 19:46 mm0qq Status new => assigned
2008-07-14 19:46 mm0qq Assigned To => jeffnik
2008-07-15 23:56 jeffnik Status assigned => acknowledged
2008-07-16 01:14 jeffnik Status acknowledged => resolved
2008-07-16 01:14 jeffnik Fixed in Version => 4.9
2008-07-16 01:14 jeffnik Resolution open => fixed
2008-07-16 01:14 jeffnik Note Added: 0000171
2008-07-28 20:33 mm0qq Status resolved => feedback
2008-07-28 20:33 mm0qq Resolution fixed => reopened
2008-07-28 20:33 mm0qq Note Added: 0000179
2008-07-29 00:59 jeffnik Status feedback => confirmed
2008-07-30 02:43 jeffnik Status confirmed => resolved
2008-07-30 02:43 jeffnik Fixed in Version 3.2 => 4.9
2008-07-30 02:43 jeffnik Resolution reopened => fixed
2008-07-30 02:43 jeffnik Note Added: 0000184