View Issue Details

IDProjectCategoryView StatusLast Update
0000206JamochaMUDOtherpublic2008-10-07 03:34
Reportermm0qqAssigned Tojeffnik 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2 
Target VersionFixed in Version3.6 
Summary0000206: Gags and Highlights settings not reloaded after upgrade
DescriptionWhen I ran 3.2 for the first time, the Gags and Highlights settings were not reloaded. After reseting them, I quit and relaunched. The G&H settings were gone, again.
Additional InformationWindows XP SP2
JAR file
TagsNo tags attached.

Activities

jeffnik

2008-07-26 19:15

administrator   ~0000177

I haven't experienced this issue on my machine, but if you can check a few things I'll see if I can resolve the problem.

The Gags & Highlights are saved in a file called .trigger.rc which should be located in your anecho/JamochaMUD/plugins/TriggerDir directory (which itself should be located where-ever Windows saves user information... most likely "Documents and Settings/username".

Once you set-up the rules you can back-up this file to a safe location... that way at least until I've fixed the problem you'll only have to copy the file back and not recreate it each time.

When you've recreated the settings and then leave the G&H dialogue, can you then go back to the dialogue and the settings are still there? I'd like to determine if they're being lost in between JamochaMUD sessions or before that.

mm0qq

2008-07-28 20:21

reporter   ~0000178

Last edited: 2008-07-31 21:53

I could not find a .trigger.rc file

I did find the folder:
C:\Documents and Settings\user\anecho\JamochaMUD
which has a .plugins.rc file, but this appears to not have the actual trigger configurations in it.

I also found the folder:
C:\Documents and Settings\user\anecho\JamochaMUD\plugins\TriggerDir
but it is empty.

jeffnik

2008-07-30 13:44

administrator   ~0000187

Last edited: 2008-07-31 22:09

Something seems to be going wrong with the creation of the .trigger.rc file, as it should only exist in the C:\Documents and Settings\user\anecho\JamochaMUD\plugins\TriggerDir directory.

I'll check the code for fall-throughs.

mm0qq

2008-10-06 17:54

reporter   ~0000193

I have found that the settings do not get saved at all.

jeffnik

2008-10-07 01:19

administrator   ~0000194

I've confirmed on a clean start the .triggers.rc file does not get created and does not seem to be saved.

jeffnik

2008-10-07 03:34

administrator   ~0000195

The method to write the rules out to a file had been disabled during refactoring. This method should be functioning again.

Issue History

Date Modified Username Field Change
2008-07-24 23:33 mm0qq New Issue
2008-07-24 23:33 mm0qq Status new => assigned
2008-07-24 23:33 mm0qq Assigned To => jeffnik
2008-07-26 19:15 jeffnik Note Added: 0000177
2008-07-28 20:21 mm0qq Note Added: 0000178
2008-07-30 13:44 jeffnik Note Added: 0000187
2008-07-31 21:53 mm0qq Note Edited: 0000178
2008-07-31 22:09 jeffnik Note Edited: 0000187
2008-10-06 17:54 mm0qq Note Added: 0000193
2008-10-07 01:19 jeffnik Note Added: 0000194
2008-10-07 03:34 jeffnik Status assigned => resolved
2008-10-07 03:34 jeffnik Fixed in Version => 4.9
2008-10-07 03:34 jeffnik Resolution open => fixed
2008-10-07 03:34 jeffnik Note Added: 0000195