View Issue Details

IDProjectCategoryView StatusLast Update
0000207JamochaMUDMain Programpublic2008-08-08 21:30
Reportermm0qqAssigned Tojeffnik 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2 
Target VersionFixed in Version3.5 
Summary0000207: control-p does not work
DescriptionControl-p does not work to recall previous command.
Control-n works fine.
TagsNo tags attached.

Activities

jeffnik

2008-07-25 00:10

administrator   ~0000176

This command was unintentionally disabled when the CTRL-UP and CTRL-DOWN arrow keys were implemented to allow command history scrolling.

CTRL-P function has been restored and will be available in the next release of JamochaMUD.

mm0qq

2008-07-28 20:40

reporter   ~0000180

Control-P now recalls the previous command, but further presses don't not "scroll" further back.
neither control-UpArrow nor control-DownArrow worked.
After using control-N to pop-up the command history, only UpArrow and DownArrow work. Control-N nor control-P nor control-UpArrow nor control-DownArrow work.

jeffnik

2008-07-28 21:41

administrator   ~0000182

CTRL-P will only display the last command that was sent to the MU*.

I was mistaken in my previous note and it is SHIFT-UpArrow and SHIFT-DownArrow (not CTRL-) that will scroll through the command history (with-out the history pop-up).

mm0qq

2008-07-28 21:52

reporter   ~0000183

Ok.

BTW, control-n seems to be the only way to get the pop-up

jeffnik

2008-08-08 21:30

administrator   ~0000189

CTRL-P works as intended, showing only the last line sent to the MU*.

Issue History

Date Modified Username Field Change
2008-07-24 23:34 mm0qq New Issue
2008-07-24 23:34 mm0qq Status new => assigned
2008-07-24 23:34 mm0qq Assigned To => jeffnik
2008-07-25 00:10 jeffnik Status assigned => resolved
2008-07-25 00:10 jeffnik Fixed in Version => 4.9
2008-07-25 00:10 jeffnik Resolution open => fixed
2008-07-25 00:10 jeffnik Note Added: 0000176
2008-07-28 20:40 mm0qq Status resolved => feedback
2008-07-28 20:40 mm0qq Resolution fixed => reopened
2008-07-28 20:40 mm0qq Note Added: 0000180
2008-07-28 21:41 jeffnik Note Added: 0000182
2008-07-28 21:52 mm0qq Note Added: 0000183
2008-08-08 21:30 jeffnik Status feedback => resolved
2008-08-08 21:30 jeffnik Fixed in Version 3.3 => 4.9
2008-08-08 21:30 jeffnik Resolution reopened => fixed
2008-08-08 21:30 jeffnik Note Added: 0000189