View Issue Details

IDProjectCategoryView StatusLast Update
0000088JamochaMUDMain Programpublic2005-09-24 21:29
Reporterthufir2Assigned Tojeffnik 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version1.1 
Summary0000088: never get a chance to login, booted right away
Descriptionsee summary. connecting with telnet works fine, this mud is either detecting something about JamochoaMUD it doesn't like, or JamochoaMUD's doing something the MUD doesn't like. :(

dunno if that's major, minor, or what!
Additional InformationAttempting connection to swmud.org...
                A long time ago, in a galaxy far, far away...
 
             ######################## ###### ###########
           ########################## ######## #############
          ########################### #### #### ##### ######
           ######## ###### #### #### #############
             ######## ###### ############ ###########
##################### ###### ############## ##### ####################
################### ###### ##### ##### ##### ###################
 
########### ## ##### ###### ########### ##################
############ #### ###### ######## ############# ####################
######################### #### #### ##### ###### #####################
       ################## #### #### ############# ########
        ################ ############ ########### ########
         ###### ###### ############## ##### #####################
          #### #### ##### ##### ##### ##################
 
  If this is your first time logging into SWMud and you are prompted for a
  password, it means that name is already in use. Please choose another name.
  In case of other problems with login, you can contact us at swmud@swmud.org.
 
To log in as a guest temporarily, use the name guest with password guest.
 
        SWmud has been up for 2 D 7 H 40 M
 
Please tell us your name: Sorry, that isn't a valid entry.
---> Connection Closed <---
TagsNo tags attached.

Relationships

has duplicate 0000090 closed login fails 

Activities

thufir2

2004-09-15 08:17

reporter   ~0000061

make the "status" public please :)

thufir2

2004-09-15 08:22

reporter   ~0000062

oops, should've been either minor or major bug. sorry, didn't check it well enough before posting.

jeffnik

2004-09-19 18:27

administrator   ~0000064

I've confirmed this problem. It may be how JamochaMUD is trying to do some telnet negotiations. I'll check into this and give an update.

jeffnik

2004-10-01 01:47

administrator   ~0000068

I've actually figured out a (monumental) problem that JamochaMUD had with telnet negotiation. JamochaMUD was sending the negotiations out using the wrong code-page, which resulted in the wrong characters, and thus failed negotations. The SWMUD saw all the gibberish coming from the client and just hung up on it.

I'll require some additional feedback now to see if changes were successful.

jeffnik

2005-03-17 03:29

administrator   ~0000071

Fixed JamochaMUD's telnet negotiation enough to allow logins.

Issue History

Date Modified Username Field Change
2004-09-15 08:16 thufir2 New Issue
2004-09-15 08:17 thufir2 Note Added: 0000061
2004-09-15 08:22 thufir2 Note Added: 0000062
2004-09-19 18:22 jeffnik View Status private => public
2004-09-19 18:27 jeffnik Note Added: 0000064
2004-09-19 18:27 jeffnik Assigned To => jeffnik
2004-09-19 18:27 jeffnik Relationship added duplicate of 0000090
2004-09-19 18:27 jeffnik Status new => assigned
2004-10-01 01:47 jeffnik Note Added: 0000068
2004-10-01 01:47 jeffnik Status assigned => feedback
2005-03-17 03:29 jeffnik Status feedback => resolved
2005-03-17 03:29 jeffnik Resolution open => fixed
2005-03-17 03:29 jeffnik Note Added: 0000071
2005-03-17 03:29 jeffnik Duplicate ID 90 => 0
2005-08-20 22:06 jeffnik Status resolved => closed
2005-09-24 21:26 jeffnik Status closed => resolved
2005-09-24 21:26 jeffnik Fixed in Version => 1.1 rc1
2005-09-24 21:29 jeffnik Status resolved => closed